OSS 3.99.3c

Official announcements from 4Front Technologies

Moderators: hannu, dev, cesium, kodachi

OSS 3.99.3c

Postby dev » Thu Sep 15, 2005 7:13 pm

We're happy to annouce OSS 3.99.3c for Linux, Solaris, BSD, LynxOS.

What's new?

- bug fixes for Linux 2.6.13 and Fedora Core4 (GCC4)
- Added LynxTWO signal lock indicators
- Fixes to ATI IXP drivers
- Intel HDA support for new HD codecs.
dev
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Re: OSS 3.99.3c

Postby Guest » Thu Nov 17, 2005 1:17 pm

dev wrote:We're happy to annouce OSS 3.99.3c for Linux, Solaris, BSD, LynxOS.

What's new?

- bug fixes for Linux 2.6.13 and Fedora Core4 (GCC4)
- Added LynxTWO signal lock indicators
- Fixes to ATI IXP drivers
- Intel HDA support for new HD codecs.


nice, but Intel HDA support for new HD codecs wont work
usb generic also (plantronics 100, protocol error)

cheers
Guest
 

Re: OSS 3.99.3c

Postby dev » Thu Nov 17, 2005 7:38 pm

Anonymous wrote:
dev wrote:We're happy to annouce OSS 3.99.3c for Linux, Solaris, BSD, LynxOS.

What's new?

- bug fixes for Linux 2.6.13 and Fedora Core4 (GCC4)
- Added LynxTWO signal lock indicators
- Fixes to ATI IXP drivers
- Intel HDA support for new HD codecs.


nice, but Intel HDA support for new HD codecs wont work
usb generic also (plantronics 100, protocol error)

cheers



For the Intel HDA you need to send us the lspci -v -n output to support@opensound.com and we'll see if the id is there or not.


As for USB - try to unplug and replug the device when you get an error.


regards
Dev Mazumdar
dev
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby gert cuykens » Thu Nov 17, 2005 8:06 pm

i updated oss but i dont understand what i have to do to make it work on ubuntu breezy ?

root@F53:/usr/lib/oss/bin # cat /usr/lib/oss/logs/soundon.log
OSS version: 3.99.3c
OSS build: 200511162253
Kernel version: Linux F53 2.6.12-9-386 #1 Mon Oct 10 13:14:36 BST 2005 i686 GNU/Linux
Kernel vermagic: 2.6.12-9-386 386 gcc-3.4
Modutils version: 3.2-pre7
21:08:38 up 48 min, 2 users, load average: 0.05, 0.08, 0.03
=== Running /usr/lib/oss/bin/soundon ===
Install directory: /usr/lib/oss
Kernel: "2.6.12-9-386 386 gcc-3.4 "
OSS: "2.6.12-9-386 386 gcc-4.0 "
Kernel and OSS module versions do not match. Removing the modules.
Will use /usr/bin/ld for linking.
Will use /usr/bin/X11/ld for linking.
make -C /lib/modules/`uname -r`/source scripts scripts_basic include/linux/version.h
make[1]: Entering directory `/usr/src/linux-headers-2.6.12-9-386'
HOSTCC scripts/basic/fixdep
/bin/sh: gcc-3.4: command not found
make[2]: *** [scripts/basic/fixdep] Error 127
make[1]: *** [scripts_basic] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.12-9-386'
make: [ossbuild] Error 2 (ignored)
make -C /lib/modules/`uname -r`/source SUBDIRS=/usr/lib/oss/kbuild CC="gcc" modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.12-9-386'
CC [M] /usr/lib/oss/kbuild/osslinux.o
Building modules, stage 2.
MODPOST
*** Warning: "oss_checksum" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
*** Warning: "oss_init_module" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
*** Warning: "touch_mixer" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
*** Warning: "oss_version_string" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
*** Warning: "oss_cardlist" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
*** Warning: "oss_cleanup_module" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
*** Warning: "num_mididevs" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
*** Warning: "oss_mixer_ext" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
*** Warning: "mixer_ext_set_enum" [/usr/lib/oss/kbuild/osslinux.ko] undefined!
CC /usr/lib/oss/kbuild/osslinux.mod.o
LD [M] /usr/lib/oss/kbuild/osslinux.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.12-9-386'
rm -f *.o *.ko *.mod.c
The kbuild method worked OK
/usr/bin/X11/ld -r -o /usr/lib/oss/modules/osslinux /usr/lib/oss/modules/sndshield /usr/lib/oss/modules/soundbase /usr/lib/oss/modules/uart401 /usr/lib/oss/modules/ac97 /usr/lib/oss/modules/intelpci -L./lib -ldrivers
Loading OSS/Linux module
insmod: error inserting '/usr/lib/oss/modules/osslinux': -1 Invalid module format
insmod: error inserting '/usr/lib/oss/modules/osslinux': -1 Invalid module format
The osslinux module didnt load. Cannot continue.
echo The osslinux module didnt load. Cannot continue.
[4294704.403000] ts: Compaq touchscreen protocol output
[4294705.601000] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[4294705.610000] NET: Registered protocol family 17
[4294710.615000] NET: Registered protocol family 10
[4294710.615000] Disabled Privacy Extensions on device c02eb280(lo)
[4294710.615000] IPv6 over IPv4 tunneling driver
[4294711.347000] ACPI: Power Button (FF) [PWRF]
[4294711.347000] ACPI: Power Button (CM) [PWRB]
[4294711.379000] ibm_acpi: ec object not found
[4294712.934000] apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
[4294712.934000] apm: overridden by ACPI.
[4294713.518000] powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.40.4)
[4294713.523000] powernow-k8: BIOS error - no PSB or ACPI _PSS objects
[4294720.712000] eth0: no IPv6 routers present
[4297033.084000] osslinux: version magic '2.6.12-9-386 386 gcc-4.0' should be '2.6.12-9-386 386 gcc-3.4'
[4297033.087000] osslinux: version magic '2.6.12-9-386 386 gcc-4.0' should be '2.6.12-9-386 386 gcc-3.4'
[4297193.741000] osslinux: version magic '2.6.12-9-386 386 gcc-4.0' should be '2.6.12-9-386 386 gcc-3.4'
[4297193.744000] osslinux: version magic '2.6.12-9-386 386 gcc-4.0' should be '2.6.12-9-386 386 gcc-3.4'
[4297573.527000] osslinux: version magic '2.6.12-9-386 386 gcc-4.0' should be '2.6.12-9-386 386 gcc-3.4'
[4297573.530000] osslinux: version magic '2.6.12-9-386 386 gcc-4.0' should be '2.6.12-9-386 386 gcc-3.4'
root@F53:/usr/lib/oss/bin #
gert cuykens
 
Posts: 28
Joined: Sat Jan 29, 2005 11:14 pm

Postby gert cuykens » Thu Nov 17, 2005 8:41 pm

finaly i got sound !!!

#!/bin/sh
#apt-get install build-essential
#apt-get install linux-headers-`uname -r`
#cat /proc/version
#apt-get install gcc-3.4
#ln -s /usr/bin/gcc-3.4 /usr/bin/gcc

rmmod snd*
rmmod soundcore
rm /dev/dsp* /dev/audio* /dev/midi* /dev/mixer* /dev/sndstat /dev/sequencer /dev/music
export KERNELINCLUDE=/lib/modules/`uname -r`/build/include
export CC=/usr/bin/gcc-3.4
soundon
gert cuykens
 
Posts: 28
Joined: Sat Jan 29, 2005 11:14 pm

Postby dev » Fri Nov 18, 2005 2:41 am

gert cuykens wrote:finaly i got sound !!!

#!/bin/sh
#apt-get install build-essential
#apt-get install linux-headers-`uname -r`
#cat /proc/version
#apt-get install gcc-3.4
#ln -s /usr/bin/gcc-3.4 /usr/bin/gcc

rmmod snd*
rmmod soundcore
rm /dev/dsp* /dev/audio* /dev/midi* /dev/mixer* /dev/sndstat /dev/sequencer /dev/music
export KERNELINCLUDE=/lib/modules/`uname -r`/build/include
export CC=/usr/bin/gcc-3.4
soundon



Glad to hear that. In general:

Kernel: "2.6.12-9-386 386 gcc-3.4 "
OSS: "2.6.12-9-386 386 gcc-4.0 "
Kernel and OSS module versions do not match. Removing the modules.


This is where you should complain loudly to your Linux distributor to make sure that the kernel and apps are compiled with the same version of GCC.


Regards
Dev
dev
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA


Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest

cron