FreeBSD 6.0 Still Not Working Dev Wake Up

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

FreeBSD 6.0 Still Not Working Dev Wake Up

Postby Chicken » Mon Nov 28, 2005 12:22 am

I dont know whats going on but its been awhile since i have been able to run oss drivers on 6.0 and be happy. I had to move to the bsd emu driver cause of all these issues. So i give it a try today

/usr/lib/oss/bin/soundon
This copy of OSS is licensed to ***

Open Sound System started OK.
ln: /dev/dsp: File exists
ln: /dev/mixer: File exists
ln: /dev/audio: File exists
ln: /dev/midi: File exists

I have no sound again.... So what is one supposed to do?
Chicken
 

Re: FreeBSD 6.0 Still Not Working Dev Wake Up

Postby dev » Mon Nov 28, 2005 5:49 pm

Chicken wrote:I dont know whats going on but its been awhile since i have been able to run oss drivers on 6.0 and be happy. I had to move to the bsd emu driver cause of all these issues. So i give it a try today

/usr/lib/oss/bin/soundon
This copy of OSS is licensed to ***

Open Sound System started OK.
ln: /dev/dsp: File exists
ln: /dev/mixer: File exists
ln: /dev/audio: File exists
ln: /dev/midi: File exists

I have no sound again.... So what is one supposed to do?



Type cat /dev/sndstat and then run osstest to see if audio works - perhaps it's a permissions issue so try as root.
dev
Developer
 
Posts: 578
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Chicken » Wed Nov 30, 2005 3:34 am

Osstest Plays Audio But i cant play any file or sound.

ran mplayer

[AO OSS] audio_setup: Can't open audio device /dev/dsp: Permission denied
/dev/dsp: Permission denied
[AO ESD] esd_open_sound failed: Permission denied

lrwxr-xr-x 1 root wheel 9 Nov 29 22:29 /dev/dsp -> /dev/dsp0

Permissions seem okay? 761

i did a chmod 777 /dev/dsp that didnt change the permission weird but now sound works?

dracula# chmod 777 /dev/dsp
dracula# ls -la /dev/dsp
lrwxr-xr-x 1 root wheel 9 Nov 29 22:29 /dev/dsp -> /dev/dsp0
Chicken
 

Postby Chicken » Wed Nov 30, 2005 3:36 am

mixer
mixer: /dev/mixer: Permission denied

I guess all permissions are wrong, but why? Its cumbersome using devfs.conf for this when a simple chmod can be added to soundon.
Chicken
 

Postby BSDKaffee » Thu Dec 01, 2005 5:03 pm

Just make a wrapper script to run soundon and change the permissions at the same time. Here's the one I use: http://www.4front-tech.com/forum/viewtopic.php?t=710
User avatar
BSDKaffee
Member
 
Posts: 28
Joined: Tue Jul 19, 2005 7:17 pm


Return to BSD

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest