sound issues

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

sound issues

Postby Sanjuro » Thu Sep 30, 2004 10:36 pm

In KDE or Windowmaker when there is sound or music playing the sound comes out very strange like a fuzzy-rattlesnaketail like sound. When I try playing mp3s that strange fuzzy noise is there, however, it sounds like a song is playing under it but very low. I also get error messages in KDE saying "Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = 472, can_write = 3765, errno = 4 (Interrupted system call)
This might be a sound hardware/driver specific problem (see aRts FAQ)"

I have tried having the sound turned on at boot but there is no difference.

Also, when I test the sound in soundconf it is normal for some reason.
Sanjuro
 

Postby Freedevil » Thu Nov 11, 2004 2:33 am

make sure kde is using the oss sound daemon.
Freedevil
 

Problems with ATI sound

Postby abzn » Fri Jul 08, 2005 6:26 pm

Freedevil wrote:make sure kde is using the oss sound daemon.

My KDE use oss sound daemon, but i have problem like someone once posted.
Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = -1, can_write = 3768, errno = 35 (Resource temporarily unavailable)
This might be a sound hardware/driver specific problem (see aRts FAQ)

I use ATI AC 97 sound card, FreeBSD 5.4, latest version oss
abzn
 

Re: Problems with ATI sound

Postby dev » Fri Jul 08, 2005 10:37 pm

abzn wrote:
Freedevil wrote:make sure kde is using the oss sound daemon.

My KDE use oss sound daemon, but i have problem like someone once posted.
Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = -1, can_write = 3768, errno = 35 (Resource temporarily unavailable)
This might be a sound hardware/driver specific problem (see aRts FAQ)

I use ATI AC 97 sound card, FreeBSD 5.4, latest version oss



Increase the fragment size setting in the Artsd (look in the sound server
setting).

Also ensure that you remove full duplex setting in Artsd.

regards

Dev Mazumdar
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby BSDKaffee » Tue Jul 19, 2005 9:14 pm

To get aRts to work reasonably with OSS, I had to disable Realtime priority and increase the soundbuffer to the maximum. I still have full duplex enabled. aRts worked alot better on a real channel, but with those tweaks, it was fine on a virtual channel.
User avatar
BSDKaffee
Member
 
Posts: 28
Joined: Tue Jul 19, 2005 7:17 pm

Re: Problems with ATI sound

Postby ALe}{ » Fri Feb 03, 2006 4:58 pm

dev wrote:
abzn wrote:
Freedevil wrote:make sure kde is using the oss sound daemon.

My KDE use oss sound daemon, but i have problem like someone once posted.
Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = -1, can_write = 3768, errno = 35 (Resource temporarily unavailable)
This might be a sound hardware/driver specific problem (see aRts FAQ)

I use ATI AC 97 sound card, FreeBSD 5.4, latest version oss



Increase the fragment size setting in the Artsd (look in the sound server
setting).

Also ensure that you remove full duplex setting in Artsd.

regards

Dev Mazumdar

can u explaint how to do it in details plz?
ALe}{
New Member
 
Posts: 3
Joined: Fri Feb 03, 2006 4:57 pm

Postby ALe}{ » Fri Feb 03, 2006 6:04 pm

here is my /dev/sndstat:
Code: Select all
OSS/FreeBSD 3.99.3d (C) 4Front Technologies 1996-2004

License serial number: E00000008
**** UNREGISTERED VERSION ****

Drivers: ALL
License will expire after: 06/2006


*** Unregistered version ***

Build: 200602030536
Kernel: FreeBSD 6.0-RELEASE #0: Thu Nov  3 09:36:13 UTC 2005
    root@x64.samsco.home:/usr/obj/usr/src/sys/GENERIC


Card config:
(MPU-401 (UART) at 0x300 irq 10)
Intel ICH AC97 audio controller at 0xe100 irq 20

Audio devices:
0: Nvidia CK8 (DUPLEX,GRC3)
1: Nvidia CK8 (shadow) (DUPLEX,GRC3)
2: Nvidia CK8 (S/PDIF) (GRC3)
3: OSS Virtual Mixer v2.5 Playback CH #0 (GRC3)
4: OSS Virtual Mixer v2.5 Playback CH #1 (GRC3)
5: OSS Virtual Mixer v2.5 Playback CH #2 (GRC3)
6: OSS Virtual Mixer v2.5 Playback CH #3 (GRC3)
7: OSS Virtual Mixer v2.5 Playback CH #4 (GRC3)
8: OSS Virtual Mixer v2.5 Playback CH #5 (GRC3)
9: OSS Virtual Mixer v2.5 Playback CH #6 (GRC3)
10: OSS Virtual Mixer v2.5 Playback CH #7 (GRC3)

Synth devices:
0: OSS Virtual Synth v2.5

Midi devices:

Mixers:
0: AC97 Mixer (ALC655)
1: Virtual Mixer

History:
dsp0: pid 1325 cmd 'artsd' IN OUT
dsp0: pid 1325 cmd 'artsd' IN OUT 132 overruns
dsp0: pid 1334 cmd 'artsd' IN OUT
dsp0: pid 1334 cmd 'artsd' IN OUT
dsp0: pid 1334 cmd 'artsd' IN OUT 58 overruns
ALe}{
New Member
 
Posts: 3
Joined: Fri Feb 03, 2006 4:57 pm

Re: Problems with ATI sound

Postby dev » Fri Feb 03, 2006 7:52 pm

ALe}{ wrote:
dev wrote:
abzn wrote:
Freedevil wrote:make sure kde is using the oss sound daemon.

My KDE use oss sound daemon, but i have problem like someone once posted.
Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = -1, can_write = 3768, errno = 35 (Resource temporarily unavailable)
This might be a sound hardware/driver specific problem (see aRts FAQ)

I use ATI AC 97 sound card, FreeBSD 5.4, latest version oss



Increase the fragment size setting in the Artsd (look in the sound server
setting).

Also ensure that you remove full duplex setting in Artsd.

regards

Dev Mazumdar

can u explaint how to do it in details plz?



Please read README.KDE-Gnome in /usr/lib/oss/docs - it tells you how to setup arts.

Also, be sure to update the system as there are some fixes regarding mmap and Non-blocking I/O that arts may be doing as well. Run /usr/lib/oss/bin/ossupdate to make sure.


best regards
Dev Mazumdar
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Re: Problems with ATI sound

Postby ALe}{ » Fri Feb 03, 2006 10:35 pm

dev wrote:Please read README.KDE-Gnome in /usr/lib/oss/docs - it tells you how to setup arts.

there is no KDE Control Panel in KDE 3.4 :cry: how to manual configure arts ?
ALe}{
New Member
 
Posts: 3
Joined: Fri Feb 03, 2006 4:57 pm

Re: Problems with ATI sound

Postby BSDKaffee » Sat Feb 11, 2006 1:44 am

ALe}{ wrote:there is no KDE Control Panel in KDE 3.4 :cry: how to manual configure arts ?
Of course there is. Click on the K Menu and "Control Center" is listed right on the menu.

If it's not there, open up a Konsole window and type: kcontrol
User avatar
BSDKaffee
Member
 
Posts: 28
Joined: Tue Jul 19, 2005 7:17 pm

poker casino685

Postby poker casino685 » Sun Feb 19, 2006 1:58 am

poker casino685
 


Return to BSD

Who is online

Users browsing this forum: Bing [Bot] and 0 guests

cron