Intel HD almost working!!

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

Intel HD almost working!!

Postby rmvg » Mon Feb 13, 2006 3:10 am

Hello i have added the script oss.sh, however even when i rename the script to oss.sh.off the oss driver still seems to load apon boot. There is a file called [oss_rules=200] in the /usr/local/etc/rc.d directory I had the below added to etc/devfs.rules

[oss_rules=200]
add path 'dsp*' mode 666
add path 'mixer*' mode 666
add path 'audio*' mode 666
add path 'midi*' mode 666
add path sequencer mode 666
add path music mode 666
add path dmfm0 mode 666

but it did not seem to make any differance so i commented them out for now do i need both the file in /usr/local/etc/rc.d and the /etc/devfs.rules? or is the latter one just an example? i installed oss to /usr/local/lib is this correct seemed like the right place for bsd.

I cannot seem to get sound unless i am root and kdm will not let me login as root anymore which i probably a good thing. when i am a normal user i get errors like this.

Failed to open audio output. You may not have permission to open the sound device, or the sound server may not be running. Please select another audio output in the Multimedia Systems Selector.

and this

he volume control did not find any elements and/or devices to control. This means either that you don't have the right GStreamer plugins installed, or that you don't have a sound card configured.

You can remove the volume control from the panel by right-clicking the speaker icon on the panel and selecting "Remove From Panel" from the menu.

ps why does oss load even when i tell it not ie renaming the script file to oss.sh.off and comment out oss_enable="YES" in /etc/rc.conf as well as the stuff in /etc/devfs.rules

Also when i run the oss.sh start i get this error

root@rachel# /usr/local/etc/rc.d/oss.sh start
Starting OSS.
**** UNREGISTERED VERSION ****


Thank you for installing Open Sound System

This unregistered version is FULLY FUNCTIONAL. You may use the unregistered
version for personal/non-commercial use only. All features of the registered
version are included in this package with the exception of technical support.

The easiest way to order OSS is using the 'Order permanent OSS license' option
of the soundconf program. Alternatively you can order the license from our
web site at: http://www.opensound.com/order.html


Open Sound System started OK.
devfs rule: ioctl DEVFSIO_SAPPLY: No such process
root@rachel#
rmvg
 

Postby BSDKaffee » Mon Feb 13, 2006 3:51 am

Are you using the newest script that I posted a few days ago? Which version of FreeBSD are you using?

The old script would run no matter what you called it as long as it was in the /usr/local/etc/rc.d directory. Renaming scripts to *.off will not keep them from running no matter what they are. If you remove the executable flag from the file, then it will not run.

The new RCng script defaults to off, so you have to specifically enable it in /etc/rc.conf.

You should NOT have a file called [oss_rules=200] in /usr/local/etc/rc.d.

You should have added to /etc/devfs.rules:
Code: Select all
[oss_rules=200]
add path 'dsp*' mode 666
add path 'mixer*' mode 666
add path 'audio*' mode 666
add path 'midi*' mode 666
add path sequencer mode 666
add path music mode 666
add path dmfm0 mode 666


The reason you can only get sound as root is because the permission rules were not being applied.

It looks like the script is starting OSS...good.
The "devfs rule: ioctl DEVFSIO_SAPPLY: No such process" error is because you commented out the rules in /etc/devfs.rules and it cannot find the ruleset to use, so uncomment them and make sure they are correct. You can keep the rules in /etc/devfs.rules even if you don't want to use OSS at the moment...they are harmless and will only be applied if devfs is called (as it is in the script).
User avatar
BSDKaffee
Member
 
Posts: 28
Joined: Tue Jul 19, 2005 7:17 pm

Postby Guest » Mon Feb 13, 2006 4:39 am

BSDKaffee wrote:Are you using the newest script that I posted a few days ago? Which version of FreeBSD are you using?

root@rachel# uname -a
FreeBSD rachel.computerking.ca 6.1-PRERELEASE FreeBSD 6.1-PRERELEASE #0: Thu Feb 9 20:37:25 MST 2006 root@rachel.computerking.ca:/usr/obj/usr/src/sys/CK06020701 i386

The old script would run no matter what you called it as long as it was in the /usr/local/etc/rc.d directory. Renaming scripts to *.off will not keep them from running no matter what they are. If you remove the executable flag from the file, then it will not run.

OK i have removed all the scripts except for one called oss.sh which is the one u posted to the sticky starts like this

#!/bin/sh

# 2006-02-10
#
# PROVIDE: oss
# REQUIRE: DAEMON
# KEYWORD: FreeBSD
#



The new RCng script defaults to off, so you have to specifically enable it in /etc/rc.conf.

You should NOT have a file called [oss_rules=200] in /usr/local/etc/rc.d.
have deleted it too

You should have added to /etc/devfs.rules:
Code: Select all
[oss_rules=200]
add path 'dsp*' mode 666
add path 'mixer*' mode 666
add path 'audio*' mode 666
add path 'midi*' mode 666
add path sequencer mode 666
add path music mode 666
add path dmfm0 mode 666


have uncommented these lines from /etc/devfs.rules

The reason you can only get sound as root is because the permission rules were not being applied.

It looks like the script is starting OSS...good.
The "devfs rule: ioctl DEVFSIO_SAPPLY: No such process" error is because you commented out the rules in /etc/devfs.rules and it cannot find the ruleset to use, so uncomment them and make sure they are correct.

Done they are correct

You can keep the rules in /etc/devfs.rules even if you don't want to use OSS at the moment...they are harmless and will only be applied if devfs is called (as it is in the script).


Still get no sound i know that mute is on by default and all i had to do as root was open ossxmix and i would have sound. But when i click on ossxmix as a regular user in gnome nothing happens. What is up with that if i try to run from a terminal i get this

rmvg@rachel$ ./ossxmix
/dev/mixer0: Permission denied

as root i get this

root@rachel# ./ossxmix
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key

Gtk-WARNING **: cannot open display: :0.0


here are the prems of that /usr/local/lib/oss/bin

total 1022
-rwx------ 1 root wheel 5172 Feb 6 16:11 checklic
-rwxr-xr-x 1 root wheel 4928 Feb 6 16:11 install_license
-rwx------ 1 root wheel 5716 Feb 6 16:11 ld10k
-rwx------ 1 root wheel 37591 Feb 6 16:11 ossctl
-rwxr-xr-x 1 root wheel 10356 Feb 6 16:11 ossinfo
-rwxr-xr-x 1 root wheel 18036 Feb 6 16:11 ossmix
-rwxr-xr-x 1 root wheel 6840 Feb 6 16:11 ossmixer
-rwxr-xr-x 1 root wheel 27432 Feb 6 16:11 ossmplay
-rwxr-xr-x 1 root wheel 17308 Feb 6 16:11 ossplay
-rwxr-xr-x 1 root wheel 10228 Feb 6 16:11 ossrecord
-rwxr-xr-x 1 root wheel 637008 Feb 6 16:11 osstest
-rwx------ 1 root wheel 14900 Feb 6 16:11 ossupdate
-rwxr-xr-x 1 root wheel 35772 Feb 6 16:11 ossxmix
-rwx------ 1 root wheel 8441 Feb 6 16:11 savemixer
-rwx------ 1 root wheel 12316 Feb 6 16:11 setfx
-rwx------ 1 root wheel 41540 Feb 6 16:11 sfxload
-rwx------ 1 root wheel 110048 Feb 6 16:11 sndconf
-rwx------ 1 root wheel 581 Sep 8 12:42 soundconf
-rwx------ 1 root wheel 37 Sep 8 12:42 soundoff
-rwx------ 1 root wheel 1681 Feb 9 01:11 soundon
Guest
 

Postby BSDKaffee » Mon Feb 13, 2006 5:21 am

You won't be able to adjust the mixer as a regular user until the correct permissions are applied.

I forgot to mention that after you put the rules in /etc/devfs.rules, you need to restart devfs, e.g:
Code: Select all
# /etc/rc.d/devfs restart

Devfs will now see the new rules that you added. After that, the script should apply the permissions properly. You only need to do that if you change the rules in /etc/devfs.rules.

I updated my post so that other people know to do that, I didn't even think about it. Hope that fixes everything.
User avatar
BSDKaffee
Member
 
Posts: 28
Joined: Tue Jul 19, 2005 7:17 pm

I reset the whole computer

Postby rmvg » Mon Feb 13, 2006 6:09 am

I reset the entire computer does that reset devfs?
because even after reboot no sound
rmvg
 

Re: I reset the whole computer

Postby dev » Tue Feb 14, 2006 9:08 pm

rmvg wrote:I reset the entire computer does that reset devfs?
because even after reboot no sound



Hi,

We found the cause for all of these permissions issue. It was that somewhere in the code we were creating all devices with the wrong permissions. Please
download the OSS 3.99.4a version or run ossupdate and let me know if this fixes the problems.

Regards
Dev Mazumdar
dev
Developer
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

cannot unload

Postby rmvg » Wed Feb 15, 2006 12:24 am

root@rachel# kldunload -f oss_mod.ko
kldunload: can't unload file: Operation not permitted

cannot get rid of oss driver now even when it is turned of in rc.conf it still loads at boottime how do i uload the drive now or even reboot without the driver starting?
rmvg
 

Postby BSDKaffee » Wed Feb 15, 2006 3:54 pm

Check /etc/rc.local and make sure OSS didn't add the startup command in there. That's the only thing I can think of...if you are using my new script, it will not start unless it is told to.
User avatar
BSDKaffee
Member
 
Posts: 28
Joined: Tue Jul 19, 2005 7:17 pm

Re: cannot unload

Postby dev » Wed Feb 15, 2006 6:53 pm

rmvg wrote:root@rachel# kldunload -f oss_mod.ko
kldunload: can't unload file: Operation not permitted

cannot get rid of oss driver now even when it is turned of in rc.conf it still loads at boottime how do i uload the drive now or even reboot without the driver starting?


You need to first exit out of X Windows session. Ensure that no audio app is running and then use soundoff to unload OSS. *you need to be root!*



regards
Dev
dev
Developer
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Guest » Wed Feb 15, 2006 10:48 pm

Yep there was a line in /etc/rc.local i removed it then i could turn sound on and off with the /etc/rc.conf file.

Nope there is no sound now not even for root anymore what the F(&k. osstest works ok as long as use ossxmix to turn off all the mute buttons and it never saves on reboot even if i use the osssave file.

, aeje vdfasfaswnvrA789807(&*z(&(&(^z*&^*tgugvkubvvvvugfugfdeujgwigbligbidbjwkgd*t@*@#$tgyg

I did not even want this stupid motherboard i was very happy with my i865 perl but that is a whole nother story

Help i really want sound even if i have to keep loging in a root forever.
Guest
 


Return to BSD

Who is online

Users browsing this forum: No registered users and 1 guest

cron