kernel panic (trap 19) when soundon command issued / FBSD6

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

kernel panic (trap 19) when soundon command issued / FBSD6

Postby neoline » Fri Feb 24, 2006 2:41 pm

Hello All there,

I am struggling with the OSS soundon. After the machnie is cold booted and the soundon command was issued the kernel panics. It says kernel trap 19, current process (sndconf). If I reboot the machine and issue the soundon command again, I will have sound. The problem appears, every time I am booting from cold, or even if I reboot, does not turn on sound, reboot again and turn on sound now, the kernel will panic. It seems, after the computer was shut off the sound wants to panic the kernel for one time :-)
My maschine is a Sony Vaio FS-415E, the cat /dev/sndstat reads
viggo:/home/and # cat /dev/sndstat
OSS/FreeBSD 3.99.4a (C) 4Front Technologies 1996-2006

License serial number: xxxxxx
This copy of OSS is licensed to Andreas Lattka
Drivers: PRO

Build: 200602162117
Kernel: FreeBSD 6.0-RELEASE-p4 #8: Sun Feb 19 22:22:46 CET 2006
and@viggo.lattka.de:/usr/obj/usr/src/sys/VIGGO


Card config:
Intel High Definition Audio (Azalia) controller at 0xb0000000 irq 16

Audio devices:
0: Intel High Definition Audio pcm-front output
1: Intel High Definition Audio pcm-center/LFE output
2: Intel High Definition Audio rec1 input
3: Intel High Definition Audio rec2 input
4: Intel High Definition Audio spdifin input
5: OSS Virtual Mixer v2.5 Playback CH #0 (GRC3)
6: OSS Virtual Mixer v2.5 Playback CH #1 (GRC3)
7: OSS Virtual Mixer v2.5 Playback CH #2 (GRC3)
8: OSS Virtual Mixer v2.5 Playback CH #3 (GRC3)
9: OSS Virtual Mixer v2.5 Playback CH #4 (GRC3)
10: OSS Virtual Mixer v2.5 Playback CH #5 (GRC3)
11: OSS Virtual Mixer v2.5 Playback CH #6 (GRC3)
12: OSS Virtual Mixer v2.5 Playback CH #7 (GRC3)

Synth devices:
0: OSS Virtual Synth v2.5

Midi devices:

Mixers:
0: Intel High Definition Audio ALC260
1: Virtual Mixer

History:
dsp0: pid 2119 cmd 'esd' OUT
dsp0: pid 2119 cmd 'esd' OUT
dsp0: pid 2119 cmd 'esd' OUT
dsp0: pid 2119 cmd 'esd' OUT
dsp0: pid 2119 cmd 'esd' OUT
viggo:/home/and #

The soundon.log has following entries for audio:
viggo:/home/and # cat /usr/local/lib/oss/logs/soundon.log | grep audio
hdaudio: RIRB timeout
hdaudio: Codec attach failed (-5)
hdaudio: RIRB timeout
viggo:/home/and #

Is there any hint about what to tune to get rid of the kernel panics?

Thank you!
neoline
New Member
 
Posts: 4
Joined: Thu Feb 23, 2006 8:56 pm

Re: kernel panic (trap 19) when soundon command issued / FBS

Postby neoline » Fri Feb 24, 2006 10:25 pm

Hi there,

I just found a possible reason for that problem:
Intel 82801FB/FR/FW/FRW (ICH6) tries to assign irq 16 to both of the usb (uhc3) device and the HDA controller. Just trying to find a possibility to adjust ...

Andreas

neoline wrote:Hello All there,

I am struggling with the OSS soundon. After the machnie is cold booted and the soundon command was issued the kernel panics. It says kernel trap 19, current process (sndconf). If I reboot the machine and issue the soundon command again, I will have sound. The problem appears, every time I am booting from cold, or even if I reboot, does not turn on sound, reboot again and turn on sound now, the kernel will panic. It seems, after the computer was shut off the sound wants to panic the kernel for one time :-)
My maschine is a Sony Vaio FS-415E, the cat /dev/sndstat reads
viggo:/home/and # cat /dev/sndstat
OSS/FreeBSD 3.99.4a (C) 4Front Technologies 1996-2006

License serial number: xxxxxx
This copy of OSS is licensed to Andreas Lattka
Drivers: PRO

Build: 200602162117
Kernel: FreeBSD 6.0-RELEASE-p4 #8: Sun Feb 19 22:22:46 CET 2006
and@viggo.lattka.de:/usr/obj/usr/src/sys/VIGGO


Card config:
Intel High Definition Audio (Azalia) controller at 0xb0000000 irq 16

Audio devices:
0: Intel High Definition Audio pcm-front output
1: Intel High Definition Audio pcm-center/LFE output
2: Intel High Definition Audio rec1 input
3: Intel High Definition Audio rec2 input
4: Intel High Definition Audio spdifin input
5: OSS Virtual Mixer v2.5 Playback CH #0 (GRC3)
6: OSS Virtual Mixer v2.5 Playback CH #1 (GRC3)
7: OSS Virtual Mixer v2.5 Playback CH #2 (GRC3)
8: OSS Virtual Mixer v2.5 Playback CH #3 (GRC3)
9: OSS Virtual Mixer v2.5 Playback CH #4 (GRC3)
10: OSS Virtual Mixer v2.5 Playback CH #5 (GRC3)
11: OSS Virtual Mixer v2.5 Playback CH #6 (GRC3)
12: OSS Virtual Mixer v2.5 Playback CH #7 (GRC3)

Synth devices:
0: OSS Virtual Synth v2.5

Midi devices:

Mixers:
0: Intel High Definition Audio ALC260
1: Virtual Mixer

History:
dsp0: pid 2119 cmd 'esd' OUT
dsp0: pid 2119 cmd 'esd' OUT
dsp0: pid 2119 cmd 'esd' OUT
dsp0: pid 2119 cmd 'esd' OUT
dsp0: pid 2119 cmd 'esd' OUT
viggo:/home/and #

The soundon.log has following entries for audio:
viggo:/home/and # cat /usr/local/lib/oss/logs/soundon.log | grep audio
hdaudio: RIRB timeout
hdaudio: Codec attach failed (-5)
hdaudio: RIRB timeout
viggo:/home/and #

Is there any hint about what to tune to get rid of the kernel panics?

Thank you!
neoline
New Member
 
Posts: 4
Joined: Thu Feb 23, 2006 8:56 pm

Postby Aphax » Sat Feb 25, 2006 7:39 am

You seem to have the exact same problem that I have (see http://4front-tech.com/forum/viewtopic.php?t=739 ), I'm just hoping it'll be fixed eventually, my BIOS is very limited and doesn't allow me to change any IRQs, all I can do is disable devices but disabling the ones I don't need still put my videocard, usb and sound on the same irq (16) :cry:
Aphax
New Member
 
Posts: 4
Joined: Thu Feb 23, 2006 12:50 am
Location: Netherlands


Return to BSD

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron