Oss 4.0 won't install on Solaris Express 3/06

OSS specific Solaris discussion (x86/SPARC)

Moderators: hannu, dev, cesium, kodachi

Oss 4.0 won't install on Solaris Express 3/06

Postby Willits » Wed Mar 22, 2006 7:13 pm

Hi dev,

I have try to install OSS 4.0 Beta on solaris 10, but I have got this bug :

bash-3.00# ossdetect -i
rem_drv ich
rem_drv midiloop
rem_drv ossusb
rem_drv softoss
rem_drv ossaudios
add_drv -m '* 0666 root sys' osscore
add_drv -m '* 0666 root sys' -i '"pci8086,24c5"' ich
devfsadm: driver failed to attach: ich
Warning: Driver (ich) successfully added to system but failed to attach
add_drv -m '* 0666 root sys' -i '"MIDILOOP"' midiloop
add_drv -m '* 0666 root sys' -i '"usbif,class1" "usb763,1001" "usb763,1002" "usb763,1014" "usb763,1015" "usbif763,classff" "usb499,1009" "usb499,101e"' ossusb
add_drv -m '* 0666 root sys' softoss
add_drv -m '* 0666 root sys' imux
drvconfig: modctl failed to add major number binding.
Ce périphérique ou cette adresse n'existe pas
add_drv -m '* 0666 root sys' imux
add_drv -m '* 0666 root sys' ossaudios



And after, I cannot run OSS.

bash-3.00# uname -a
SunOS Chronos 5.11 snv_33 i86pc i386 i86pc
bash


Thanks,

Willits.
Willits
Member
 
Posts: 13
Joined: Wed Feb 16, 2005 2:27 pm

Re: Oss 4.0 won't install on Solaris Express 3/06

Postby dev » Wed Mar 22, 2006 11:25 pm

Willits wrote:Hi dev,

I have try to install OSS 4.0 Beta on solaris 10, but I have got this bug :

bash-3.00# ossdetect -i
rem_drv ich
rem_drv midiloop
rem_drv ossusb
rem_drv softoss
rem_drv ossaudios
add_drv -m '* 0666 root sys' osscore
add_drv -m '* 0666 root sys' -i '"pci8086,24c5"' ich
devfsadm: driver failed to attach: ich
Warning: Driver (ich) successfully added to system but failed to attach
add_drv -m '* 0666 root sys' -i '"MIDILOOP"' midiloop
add_drv -m '* 0666 root sys' -i '"usbif,class1" "usb763,1001" "usb763,1002" "usb763,1014" "usb763,1015" "usbif763,classff" "usb499,1009" "usb499,101e"' ossusb
add_drv -m '* 0666 root sys' softoss
add_drv -m '* 0666 root sys' imux
drvconfig: modctl failed to add major number binding.
Ce périphérique ou cette adresse n'existe pas
add_drv -m '* 0666 root sys' imux
add_drv -m '* 0666 root sys' ossaudios



And after, I cannot run OSS.

bash-3.00# uname -a
SunOS Chronos 5.11 snv_33 i86pc i386 i86pc
bash


Thanks,

Willits.


Seems like you have problems with Solaris that aren't OSS related at all.
We have OSS working on B30, 33 and 34 no problems here.

You might need to reboot into failsafe mode and then uninstall OSS by running pkgrm -r /a oss


best regards
Dev Mazumdar
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Willits » Mon Mar 27, 2006 10:18 am

Thank dev, now this work very fine.
Willits
Member
 
Posts: 13
Joined: Wed Feb 16, 2005 2:27 pm


Return to Solaris

Who is online

Users browsing this forum: No registered users and 1 guest

cron