osstest result on sol-10 x86 [need help to understand it]

OSS specific Solaris discussion (x86/SPARC)

Moderators: hannu, dev, cesium, kodachi

osstest result on sol-10 x86 [need help to understand it]

Postby hasan » Fri Apr 21, 2006 11:32 am

Dear All

I'm going to paste the osstest result here. The test played the sound left, right and then stereo. But in the end it displayed there were errors detected. kindly help me understand the result. Also, to play audio (all common types like audio CDs, mp3 etc) Do i have to install a media player like xmms, mplayer or realplayer [realplayer is available for solaris but will it work with oss driver on solaris?]? i tried to play an audio cd through java media player, but there was no sound, neither it displayed any errors. Following is the result when i typed "osstest" at the prompt:-

# osstest

*** Scanning sound adapter #-1 ***
/dev/dsp0 ESS Maestro3 (ESS1998) (adapter5, subdev1)
- Performing audio playback test... /dev/dsp0: Device busy
The device is busy. There is some other application
using it.
Can't open the device
/dev/dsp1 ESS Maestro3 (ESS1998) (shadow) (adapter5, subdev2)
- Skipping device (card already tested)

*** Scanning sound adapter #5 ***
/dev/dsp2 OSS Virtual Mixer v3.0 Rec/Play CH #0 (adapter3, subdev1)
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <real srate 47823.00 Hz (-0.37%)>
/dev/dsp3 OSS Virtual Mixer v3.0 Rec/Play CH #1 (adapter3, subdev2)
- Skipping virtual device (use -V to force test)
/dev/dsp4 OSS Virtual Mixer v3.0 Rec/Play CH #2 (adapter3, subdev3)
- Skipping virtual device (use -V to force test)
/dev/dsp5 OSS Virtual Mixer v3.0 Rec/Play CH #3 (adapter3, subdev4)
- Skipping virtual device (use -V to force test)
/dev/dsp6 OSS Virtual Mixer v3.0 Rec/Play CH #4 (adapter3, subdev5)
- Skipping virtual device (use -V to force test)
/dev/dsp7 OSS Virtual Mixer v3.0 Rec/Play CH #5 (adapter3, subdev6)
- Skipping virtual device (use -V to force test)
/dev/dsp8 OSS Virtual Mixer v3.0 Rec/Play CH #6 (adapter3, subdev7)
- Skipping virtual device (use -V to force test)
/dev/dsp9 OSS Virtual Mixer v3.0 Rec/Play CH #7 (adapter3, subdev8)
- Skipping virtual device (use -V to force test)
/dev/dsp10 Virtual Mixer Loopback Record CH #0 (adapter3, subdev9)
- Skipping input only device
/dev/dsp11 Virtual Mixer Loopback Record CH #1 (adapter3, subdev10)
- Skipping input only device
/dev/dsp12 Virtual Mixer Loopback Record CH #2 (adapter3, subdev11)
- Skipping input only device
/dev/dsp13 Virtual Mixer Loopback Record CH #3 (adapter3, subdev12)
- Skipping input only device

*** Some errors were detected during the tests ***
hasan
New Member
 
Posts: 1
Joined: Fri Apr 21, 2006 11:23 am

Re: osstest result on sol-10 x86 [need help to understand it

Postby dev » Fri Apr 21, 2006 5:59 pm

hasan wrote:Dear All

I'm going to paste the osstest result here. The test played the sound left, right and then stereo. But in the end it displayed there were errors detected. kindly help me understand the result. Also, to play audio (all common types like audio CDs, mp3 etc) Do i have to install a media player like xmms, mplayer or realplayer [realplayer is available for solaris but will it work with oss driver on solaris?]? i tried to play an audio cd through java media player, but there was no sound, neither it displayed any errors. Following is the result when i typed "osstest" at the prompt:-

# osstest

*** Scanning sound adapter #-1 ***
/dev/dsp0 ESS Maestro3 (ESS1998) (adapter5, subdev1)
- Performing audio playback test... /dev/dsp0: Device busy
The device is busy. There is some other application
using it.
Can't open the device
/dev/dsp1 ESS Maestro3 (ESS1998) (shadow) (adapter5, subdev2)
- Skipping device (card already tested)

*** Scanning sound adapter #5 ***
/dev/dsp2 OSS Virtual Mixer v3.0 Rec/Play CH #0 (adapter3, subdev1)
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <real srate 47823.00 Hz (-0.37%)>
/dev/dsp3 OSS Virtual Mixer v3.0 Rec/Play CH #1 (adapter3, subdev2)
- Skipping virtual device (use -V to force test)
/dev/dsp4 OSS Virtual Mixer v3.0 Rec/Play CH #2 (adapter3, subdev3)
- Skipping virtual device (use -V to force test)
/dev/dsp5 OSS Virtual Mixer v3.0 Rec/Play CH #3 (adapter3, subdev4)
- Skipping virtual device (use -V to force test)
/dev/dsp6 OSS Virtual Mixer v3.0 Rec/Play CH #4 (adapter3, subdev5)
- Skipping virtual device (use -V to force test)
/dev/dsp7 OSS Virtual Mixer v3.0 Rec/Play CH #5 (adapter3, subdev6)
- Skipping virtual device (use -V to force test)
/dev/dsp8 OSS Virtual Mixer v3.0 Rec/Play CH #6 (adapter3, subdev7)
- Skipping virtual device (use -V to force test)
/dev/dsp9 OSS Virtual Mixer v3.0 Rec/Play CH #7 (adapter3, subdev8)
- Skipping virtual device (use -V to force test)
/dev/dsp10 Virtual Mixer Loopback Record CH #0 (adapter3, subdev9)
- Skipping input only device
/dev/dsp11 Virtual Mixer Loopback Record CH #1 (adapter3, subdev10)
- Skipping input only device
/dev/dsp12 Virtual Mixer Loopback Record CH #2 (adapter3, subdev11)
- Skipping input only device
/dev/dsp13 Virtual Mixer Loopback Record CH #3 (adapter3, subdev12)
- Skipping input only device

*** Some errors were detected during the tests ***



You need to log out from JDS and then log in on the console and run the osstest. JDS starts the audio manager that opens the device and so nothing else can use that device.

If you don't get any audio, look at the man allegro and edit the allegro.conf file in /platform/i86pc/drv and set the allegro_amp=1 and reboot.



regards
Dev mazumdar
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA


Return to Solaris

Who is online

Users browsing this forum: No registered users and 1 guest