sound only with root

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, kodachi, cesium

sound only with root

Postby dr » Sun Oct 29, 2006 10:58 am

Hi,

With FreeBSD 6.1 and Gnome, I have sound only in root...

I tried to chage permissions for all files in /dev, but nothing

And the cd player of gnome tell me "error disk" and take a very long time to start.

And this only when 'm not root user

Thanks to help me

David
dr
 
Posts: 4
Joined: Sun Oct 29, 2006 10:46 am

Re: sound only with root

Postby dev » Sun Oct 29, 2006 5:23 pm

dr wrote:Hi,

With FreeBSD 6.1 and Gnome, I have sound only in root...

I tried to chage permissions for all files in /dev, but nothing

And the cd player of gnome tell me "error disk" and take a very long time to start.

And this only when 'm not root user

Thanks to help me

David



Which version of OSS are you using?
It used to be a problem but now it's been fixed.

best regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby dr » Sun Oct 29, 2006 6:09 pm

my version of OSS is 3.99.4c

Thank you for your reply

David
dr
 
Posts: 4
Joined: Sun Oct 29, 2006 10:46 am

Postby dev » Sun Oct 29, 2006 10:26 pm

dr wrote:my version of OSS is 3.99.4c

Thank you for your reply

David


OSS Creates the device modes with 0666 (rw-rw-rw) so it should be fine. You should try this

1) run soundoff
2) rm -f /dev/dsp* /dev/mixer* /dev/sndstat /dev/midi*
3) run soundon and type ls -l /dev/dsp to see if the perms are correct.



regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby dr » Mon Oct 30, 2006 9:04 pm

Hi,

I tried what you told me into 2 diffrents computer and one works fine with OSS

but mine doesn't work with other user than root .. :cry:

both of them run under FreeBSD 6.1 of the same version with gnome of the same version

the perms are correct

But maybe I made mistake with something (for example I don't what is ESD from gnome...)

thanks

David
dr
 
Posts: 4
Joined: Sun Oct 29, 2006 10:46 am

Postby dr » Mon Oct 30, 2006 9:18 pm

rehi,

sorry, but I solved the probleme ... :lol:

In gnome

I go to System -> prefs -> sound

In "Device" I change everything to ESD (default is Autodetect)

And in "sound" I click two times on mixing software sound (ESD) (one time to uncheck and another to check)

And everything work very fine, I don't know why but it works

Thank you very much for your help

David
dr
 
Posts: 4
Joined: Sun Oct 29, 2006 10:46 am


Return to BSD

Who is online

Users browsing this forum: No registered users and 1 guest

cron