Board Intel 850EMV2 under Solaris 11 Nevada b61

OSS specific Solaris discussion (x86/SPARC)

Moderators: cesium, dev, kodachi, hannu

Board Intel 850EMV2 under Solaris 11 Nevada b61

Postby skolnick » Sun Apr 08, 2007 7:29 pm

Hi!

I am using Solaris nevada b61 with this motherboard (pretty old P4 board): http://www.intel.com/design/motherbd/mv2/. I installed latest oss, but sound will not work, here's what I get:

Code: Select all
bash-3.00$ ossinfo
Version info: OSS 4.0 (build 1002/200704040101) (0x00040002)
Platform: SunOS/i86pc 5.11 snv_61

Number of audio devices:        1
Number of audio engines:        6
Number of MIDI devices:         0
Number of mixer devices:        1


Device objects
0: oss0 OSS core services
1: ossusb0 USB audio/MIDI device
2: vmix0 OSS transparent virtual support
3: sadasupport0 SADA compatibility layer
4: ich0 Intel ICH2 (2445)

MIDI devices (/dev/midi*)

Mixer devices (/dev/mixer*)
0: ICH AC97 Mixer (AD1885) (Mixer 0 of device object 4)

Audio devices
/dev/oss/ich0/pcm0      Intel ICH2 (2445)  (device index 0)
bash-3.00$ osstest
Sound subsystem and version: OSS 4.0 (build 1002/200704040101) (0x00040002)
Platform: SunOS/i86pc 5.11 snv_61

*** Scanning sound adapter #-1 ***
/dev/oss/ich0/pcm0 (audio engine 0): Intel ICH2 (2445)
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured>

*** All tests completed OK ***
bash-3.00$$ ossmix
Selected mixer 0/
Known controls are:
        vol <both>[:<rightvol>] (currently 75:75)
        vol.rec ON|OFF (currently OFF)
        pcm <both>[:<rightvol>] (currently 75:75)
        speaker <monovol> (currently 0)
        line <both>[:<rightvol>] (currently 32:32)
        line.rec ON|OFF (currently ON)
        mic <monovol> (currently 0)
        mic.rec ON|OFF (currently OFF)
        cd <both>[:<rightvol>] (currently 75:75)
        cd.rec ON|OFF (currently OFF)
        igain <both>[:<rightvol>] (currently 75:75)
        aux1 <both>[:<rightvol>] (currently 32:32)
        aux1.rec ON|OFF (currently OFF)
        phone <both>[:<rightvol>] (currently 0:0)
        phone.rec ON|OFF (currently OFF)
        mono <monovol> (currently 75)
        mono.rec ON|OFF (currently OFF)
        video <both>[:<rightvol>] (currently 0:0)
        video.rec ON|OFF (currently OFF)
        depth <monovol> (currently 0)
        vmix0-src <Fast> (currently OFF)
        vmix0-vol <monovol> (currently 25.0 dB)
        vmix0-out <leftVU>:<rightVU>] (currently 0:0)
        vmix0-out.dsp2 <monovol> (currently 25.0 dB)
        vmix0-out <leftVU>:<rightVU>] (currently 0:0)
        vmix0-out.dsp3 <monovol> (currently 25.0 dB)
        vmix0-out <leftVU>:<rightVU>] (currently 0:0)
        vmix0-out.dsp4 <monovol> (currently 25.0 dB)
        vmix0-out <leftVU>:<rightVU>] (currently 0:0)
        vmix0-out.dsp5 <monovol> (currently 25.0 dB)
        vmix0-out <leftVU>:<rightVU>] (currently 0:0)
        vmix0-in <leftVU>:<rightVU>] (currently 0:0)
bash-3.00$

As can be seen in osstest, it seems to be playing something, just way too fast, so nothing comes out the speakers. This happens just after installing oss (no rebbot yet). After rebooting, I get this:
Code: Select all
bash-3.00$ osstest
Sound subsystem and version: OSS 4.0 (build 1002/200704040101) (0x00040002)
Platform: SunOS/i86pc 5.11 snv_61

*** Scanning sound adapter #-1 ***
/dev/oss/ich0/pcm0 (audio engine 0): Intel ICH2 (2445)
- Device busy (opened by PID 0/VMIX)

*** All tests completed OK ***
bash-3.00$ ossdetect
rem_drv ich
Device busy
Cannot unload module: ich
Will be unloaded upon reboot.
rem_drv ossusb
rem_drv vmix
Device busy
Cannot unload module: vmix
Will be unloaded upon reboot.
rem_drv sadasupport
Device busy
Cannot unload module: sadasupport
Will be unloaded upon reboot.
Device busy
Cannot unload module: osscore
Will be unloaded upon reboot.
add_drv -m '* 0666 root sys' osscore
add_drv -m '* 0666 root sys' -i '"pci8086,2445"' ich
add_drv -m '* 0666 root sys' -i '"usbif,class1" "usb763,1001" "usb763,1002" "usb763,1014" "usb763,1015" "usbif763,classff" "usb499,1009" "usb499,101e"' ossusb
add_drv -m '* 0666 root sys' vmix
add_drv -m '* 0666 root sys' sadasupport
bash-3.00$


Any idea what can be going wrong? The hardware for sure has no problem, since it works under Fedora Core 6, Windows XP and Windows Vista.

Thanks!
skolnick
Member
 
Posts: 12
Joined: Mon Jan 01, 2007 9:22 pm

Postby dev » Tue Apr 10, 2007 11:54 pm

edit /usr/lib/oss/etc/ich.conf and set the ich_rate_tuning parameter
(type man ich to figure out the value to put)
dev
Developer
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby skolnick » Thu Apr 12, 2007 6:17 pm

Hi dev

I edited the file, (I had to create it, there was no ich.conf file) it resulted like this:

Code: Select all
bash-3.00$ cat /usr/lib/oss/etc/ich.conf
intelpci_rate_tuning=8805132

bash-3.00$

However, still the issue is the same. No sound, and this very high srate:

Code: Select all
bash-3.00$ osstest
Sound subsystem and version: OSS 4.0 (build 1002/200704040101) (0x00040002)
Platform: SunOS/i86pc 5.11 snv_61

*** Scanning sound adapter #-1 ***
/dev/oss/ich0/pcm0 (audio engine 0): Intel ICH2 (2445)
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK measured srate 3642131.02 Hz (7487.77%)

*** All tests completed OK ***
bash-3.00$


I had to remove the "<" and ">" from the measure part because for some reason if I don't do that, it will not show the interesting part, which is the measured srate (it will show only <measured>, I think it's a problem with the forum's software).

Thanks for any other hint!

German Andres.
skolnick
Member
 
Posts: 12
Joined: Mon Jan 01, 2007 9:22 pm


Return to Solaris

Who is online

Users browsing this forum: No registered users and 1 guest