OSS has not detected any supported sound hardware...

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

OSS has not detected any supported sound hardware...

Postby Strat » Sun Sep 02, 2007 4:52 pm

I am running PC-BSD 1.4 Beta in Parallels on a new Aluminum iMac. I installed OSS and everything seemed to go fine. When I run osstest it says:

OSS has not detected any supported sound hardware in your system.

When I type "ossdetect -v" i get:

Detected OSS Transparent Virtual Mixing Architecture

I have no sound. What is the problem here? Should more stuff be showing up than just the Transparent Virtual Mixing Architecture? What do I need to do? Thanks in advance.
Strat
New Member
 
Posts: 2
Joined: Sun Sep 02, 2007 4:47 pm

Re: OSS has not detected any supported sound hardware...

Postby Oko » Thu Sep 13, 2007 8:28 am

Strat wrote:I am running PC-BSD 1.4 Beta in Parallels on a new Aluminum iMac. I installed OSS and everything seemed to go fine. When I run osstest it says:

OSS has not detected any supported sound hardware in your system.

When I type "ossdetect -v" i get:

Detected OSS Transparent Virtual Mixing Architecture

I have no sound. What is the problem here? Should more stuff be showing up than just the Transparent Virtual Mixing Architecture? What do I need to do? Thanks in advance.


PC-BSD is shipping with binaries only. You need system tree for OSS to work. You need cvsup standardsupfile or whatever. Read the handbook. You also need oss_enable="YES" in your /etc/rc.conf file.

Did you compile OSS form ports or you were using binaries form the OSS website?

You need to show as
dmesg

as well

oss-info and oss-test before

Did you read the documentatin for Open Sound System?
Oko
Member
 
Posts: 11
Joined: Fri Aug 03, 2007 10:52 pm
Location: Arizona

Postby Strat » Sat Sep 15, 2007 4:54 pm

I already installed the system source. I put oss_enable="YES" in my /etc/rc.conf file. I tried installing OSS from both the website and from ports. dmesg says:

%dmesg
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-STABLE #50: Wed Jul 18 13:26:35 PDT 2007
root@pcbsd:/usr/obj/usr/src/sys/PCBSD-SMP
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM)2 Duo CPU T7700 @ 2.40GHz (2392.05-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x6fa Stepping = 10
Features=0xf80b9b9<FPU>
Features2=0x1<SSE3>
real memory = 1073741824 (1024 MB)
avail memory = 1041555456 (993 MB)
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
cpu0 on motherboard
pcib0: <Intel> pcibus 0 on motherboard
pir0: <PCI> on motherboard
pci0: <PCI> on pcib0
pci0: <display> at device 2.0 (no driver attached)
pci0: <bridge> at device 3.0 (no driver attached)
ed0: <RealTek> port 0x4c00-0x4c1f irq 10 at device 5.0 on pci0
ed0: Ethernet address: 00:1c:42:68:c6:ed
ed0: type RTL8029 (16 bit)
agp0: <Intel> mem 0xe0000000-0xe3ffffff at device 30.0 on pci0
isab0: <PCI> at device 31.0 on pci0
isa0: <ISA> on isab0
atapci0: <Intel> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x5000-0x500f at device 31.1 on pci0
ata0: <ATA> on atapci0
ata1: <ATA> on atapci0
pmtimer0 on isa0
orm0: <ISA> at iomem 0xc0000-0xc9fff on isa0
atkbdc0: <Keyboard> at port 0x60,0x64 on isa0
atkbd0: <AT> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS> flags 0x1000 irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model IntelliMouse Explorer, device ID 4
ppc0: parallel port not found.
sc0: <System> at flags 0x100 on isa0
sc0: VGA <16>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 2392047864 Hz quality 800
Timecounters tick every 1.000 msec
ad0: 10000MB <Virtual> at ata0-master UDMA100
acd0: DVDR <PRL> at ata0-slave PIO4
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
cd0 at ata0 bus 0 target 1 lun 0
cd0: <MATSHITA> Removable CD-ROM SCSI-0 device
cd0: 16.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Trying to mount root from ufs:/dev/ad0s1a
ppc0: parallel port not found.
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
ppc0: parallel port not found.
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
ppc0: parallel port not found.
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
ppc0: parallel port not found.
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
ppc0: parallel port not found.
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
ppc0: parallel port not found.
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
ppc0: parallel port not found.
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
logo_saver: the console does not support M_VGA_CG320
module_register_init: MOD_LOAD (logo_saver, 0xc51a59f8, 0) error 19
%
Strat
New Member
 
Posts: 2
Joined: Sun Sep 02, 2007 4:47 pm

Postby Oko » Wed Sep 19, 2007 2:34 am

Do you have idiotic RealTek Sound Card?
OSS is not going to help you but hnd driver from Ariff might if you know what are you doing.
Oko
Member
 
Posts: 11
Joined: Fri Aug 03, 2007 10:52 pm
Location: Arizona


Return to BSD

Who is online

Users browsing this forum: Majestic-12 [Bot], Yahoo [Bot] and 1 guest