sound repeating if osstest not run after soundon..

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, kodachi, cesium

sound repeating if osstest not run after soundon..

Postby Guest » Thu Sep 30, 2004 9:41 pm

Hi,

My problem is that the sound on xmms is repeating over and over (like some sort of echo) when I run soundon without a soundtest after..

Thanks for your help
Guest
 

Postby Guest » Thu Sep 30, 2004 9:42 pm

Using Asus a7n8x Deluxe nforce2
Guest
 

Postby Guest » Fri Oct 01, 2004 6:07 am

I'm using /dev/dsp2 output the sound to the spdif, and I found out that this repeating bug is going away if I try to play some sound to /dev/dsp0 (analog output) prior to playing to /dev/dsp2..

Any idea ?
Guest
 

Postby dev » Fri Oct 01, 2004 5:29 pm

Anonymous wrote:I'm using /dev/dsp2 output the sound to the spdif, and I found out that this repeating bug is going away if I try to play some sound to /dev/dsp0 (analog output) prior to playing to /dev/dsp2..

Any idea ?


We'll check out the bug and figure out what's going on.

Just make sure that you don't have any memory allocation errors. Run
soundoff and soundon and make sure that there are no malloc messages
in dmesg spewed by OSS.

What version of FreeBSD are you on?

regards
Dev
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Guest » Sun Oct 03, 2004 9:15 am

Here are all the relevant information.
In dmesg an error with oss occurs, but that could be the dolby d device shipped with the nforce2 chip that is not detected.

-su-3.00# soundoff
-su-3.00# soundon


IMPORTANT!

The following OSS drivers required for your current
hardware configuration: INTEL

Warning: Some of the devices failed to initialize
-su-3.00# dmesg
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 5.2.1-RELEASE #1: Fri Oct 1 00:03:15 CEST 2004
root@amorphous.serpe.org:/usr/src/sys/i386/compile/AMORPHOUS
Preloaded elf kernel "/boot/kernel/kernel" at 0xc09e3000.
mptable_probe: Unable to map end of MP Config Table
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) processor (1336.37-MHz 686-class CPU)
Origin = "AuthenticAMD" Id = 0x642 Stepping = 2
Features=0x183fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CM
OV,PAT,PSE36,MMX,FXSR>
AMD Features=0xc0440000<RSVD,AMIE,DSP,3DNow!>
real memory = 536805376 (511 MB)
avail memory = 511774720 (488 MB)
Pentium Pro MTRR support enabled
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcibios: BIOS version 2.10
Using $PIR table, 11 entries at 0xc00fdeb0
pcib0: <Host to PCI bridge> at pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
agp0: <NVIDIA nForce2 AGP Controller> mem 0xd0000000-0xd7ffffff at device 0.0 on
pci0
pci0: <memory, RAM> at device 0.1 (no driver attached)
pci0: <memory, RAM> at device 0.2 (no driver attached)
pci0: <memory, RAM> at device 0.3 (no driver attached)
pci0: <memory, RAM> at device 0.4 (no driver attached)
pci0: <memory, RAM> at device 0.5 (no driver attached)
isab0: <PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xea086000-0xea086fff irq 11 at devic
e 2.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: (0x10de) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ums0: Microsoft Microsoft IntelliMouse\M-. Optical, rev 1.10/1.21, addr 2, iclas
s 3/1
ums0: 5 buttons and Z dir.
ohci1: <OHCI (generic) USB controller> mem 0xea082000-0xea082fff irq 5 at device
2.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: (0x10de) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
pci0: <serial bus, USB> at device 2.2 (no driver attached)
pci0: <multimedia, audio> at device 5.0 (no driver attached)
pci0: <multimedia, audio> at device 6.0 (no driver attached)
pcib1: <PCIBIOS PCI-PCI bridge> at device 8.0 on pci0
pci1: <PCI bus> on pcib1
pci_cfgintr: 1:7 INTA BIOS irq 11
vr0: <VIA VT6102 Rhine II 10/100BaseTX> port 0xc000-0xc0ff mem 0xe9000000-0xe900
00ff irq 11 at device 7.0 on pci1
vr0: Ethernet address: 00:50:ba:2e:eb:b2
miibus0: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
atapci0: <nVidia nForce2 UDMA133 controller> port 0xf000-0xf00f at device 9.0 on
pci0
ata0: at 0x1f0 irq 14 on atapci0
ata0: [MPSAFE]
ata1: at 0x170 irq 15 on atapci0
ata1: [MPSAFE]
fwohci0: vendor=10de, dev=6e
fwohci0: <1394 Open Host Controller Interface> mem 0xea084000-0xea08403f,0xea083
000-0xea0837ff irq 11 at device 13.0 on pci0
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channel is 4.
fwohci0: EUI64 00:e0:18:00:00:1a:be:07
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:e0:18:1a:be:07
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
fwohci0: phy int
pcib2: <PCI-PCI bridge> at device 30.0 on pci0
pci2: <PCI bus> on pcib2
pci_cfgintr: 0:30 INTA routed to irq 11
pcib2: slot 0 INTA is routed to irq 11
pci2: <display, VGA> at device 0.0 (no driver attached)
pmtimer0 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x64,0x60 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> at port 0x3f7,0x3f
0-0x3f5 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
unknown: <PNP0303> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0700> can't assign resources (port)
unknown: <PNP0401> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
Timecounter "TSC" frequency 1336373604 Hz quality 800
Timecounters tick every 10.000 msec
acd0: DVDROM <Pioneer DVD-ROM ATAPIModel DVD-106S 0122> at ata0-master PIO4
acd1: CDRW <Memorex Twelve MAXX 1032> at ata0-slave PIO4
GEOM: create disk ad2 dp=0xc48cdd60
ad2: 38166MB <WDC WD400BB-00FJA0> [77545/16/63] at ata1-master UDMA100
GEOM: create disk ad3 dp=0xc48cdb60
ad3: 114473MB <ST3120026A> [232581/16/63] at ata1-slave UDMA100
Mounting root from ufs:/dev/ad2s1a
oss: Probing the hardware for MPU-401 (UART) failed.
oss: Probing the hardware for MPU-401 (UART) failed.
-su-3.00# uname -a
FreeBSD amorphous.serpe.org 5.2.1-RELEASE FreeBSD 5.2.1-RELEASE #1: Fri Oct 1 0
0:03:15 CEST 2004 root@amorphous.serpe.org:/usr/src/sys/i386/compile/AMORPHO
US i386
-su-3.00#
Guest
 

Postby GraveR » Fri Oct 29, 2004 8:39 pm

Yup, same problem here. FreeBSD 5.3-RC1 on an Gigabyte 7NNXP mainboard. Same problem, same 'fix'

Code: Select all
Starting OSS/FreeBSD  3.99.1h Fri Oct 29 22:34:27 CEST 2004
10:34PM  up 17 mins, 1 user, load averages: 0.00, 0.04, 0.05
======= config =====
# Use soundconf to edit this file.
/SECUREAUDIO OFF
/PCIIRQ 1 5
/IRQEXCLUDE 3 4
/DMAEXCLUDE 2
-PCI006a10de #Nvidia nForce2
INTELPCI ON
UART401 ON P330 I10
====== pnpres.dat ========
====================
OSS/FreeBSD 3.99.1h (C) 4Front Technologies 1996-2004

License serial number: N02700964
Drivers: INTELPCI SBLIVE
This copy of OSS is licensed to Frits Letteboer

Build: 200410161216
Kernel: FreeBSD 5.3-RC1 #0: Fri Oct 29 19:05:19 CEST 2004
    root@graver.dragonball.z:/usr/obj/usr/src/sys/GRAVER


Card config:
Intel ICH AC97 audio controller at 0xe000 irq 21
MPU-401 (UART) at 0x330 irq 10

Audio devices:
0: Nvidia nForce2 (DUPLEX)
1: Nvidia nForce2 (shadow) (DUPLEX)
2: Nvidia nForce2 (S/PDIF) (GRC3)
3: OSS Virtual Mixer v2.5 Playback CH #0 (GRC3)
4: OSS Virtual Mixer v2.5 Playback CH #1 (GRC3)
5: OSS Virtual Mixer v2.5 Playback CH #2 (GRC3)
6: OSS Virtual Mixer v2.5 Playback CH #3 (GRC3)
7: OSS Virtual Mixer v2.5 Playback CH #4 (GRC3)
8: OSS Virtual Mixer v2.5 Playback CH #5 (GRC3)
9: OSS Virtual Mixer v2.5 Playback CH #6 (GRC3)
10: OSS Virtual Mixer v2.5 Playback CH #7 (GRC3)

Synth devices:
0: OSS Virtual Synth v2.5

Midi devices:
0: MPU-401 (UART)

Mixers:
0: AC97 Mixer (ALC650)
1: Virtual Mixer

History:
dsp6: pid 866 cmd '<CE><FA><EF><BE>sndconf' OUT
dsp7: pid 866 cmd '<CE><FA><EF><BE>sndconf' OUT
dsp8: pid 866 cmd '<CE><FA><EF><BE>sndconf' OUT
dsp9: pid 866 cmd '<CE><FA><EF><BE>sndconf' OUT
dsp10: pid 866 cmd '<CE><FA><EF><BE>sndconf' OUT
========== dmesg printout follows ========
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.3-RC1 #0: Fri Oct 29 19:05:19 CEST 2004
    root@graver.dragonball.z:/usr/obj/usr/src/sys/GRAVER
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) XP 3200+ (2191.24-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x6a0  Stepping = 0
  Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
  AMD Features=0xc0400000<AMIE,DSP,3DNow!>
real memory  = 1073676288 (1023 MB)
avail memory = 1041117184 (992 MB)
ACPI APIC Table: <Nvidia AWRDACPI>
ioapic0 <Version 1.1> irqs 0-23 on motherboard
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <Nvidia AWRDACPI> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf0-0xcf3,0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <NVIDIA nForce2 AGP Controller> mem 0xe0000000-0xe3ffffff at device 0.0 on pci0
pci0: <memory, RAM> at device 0.1 (no driver attached)
pci0: <memory, RAM> at device 0.2 (no driver attached)
pci0: <memory, RAM> at device 0.3 (no driver attached)
pci0: <memory, RAM> at device 0.4 (no driver attached)
pci0: <memory, RAM> at device 0.5 (no driver attached)
isab0: <PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xed085000-0xed085fff irq 22 at device 2.0 on pci0
ohci0: [GIANT-LOCKED]
usb0: OHCI version 1.0, legacy support
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ums0: Logitech USB-PS/2 Optical Mouse, rev 2.00/11.00, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.
ohci1: <OHCI (generic) USB controller> mem 0xed081000-0xed081fff irq 21 at device 2.1 on pci0
ohci1: [GIANT-LOCKED]
usb1: OHCI version 1.0, legacy support
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
uhub2: Standard Microsystems product 0xa700, class 9/0, rev 2.00/0.00, addr 2
uhub2: 4 ports with 4 removable, self powered
pci0: <serial bus, USB> at device 2.2 (no driver attached)
pci0: <multimedia, audio> at device 5.0 (no driver attached)
pci0: <multimedia, audio> at device 6.0 (no driver attached)
pcib1: <ACPI PCI-PCI bridge> at device 8.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <multimedia, video> at device 7.0 (no driver attached)
pci1: <multimedia> at device 7.1 (no driver attached)
pci1: <multimedia> at device 7.2 (no driver attached)
pci1: <network> at device 10.0 (no driver attached)
em0: <Intel(R) PRO/1000 Network Connection, Version - 1.7.35> port 0x8400-0x843f mem 0xec000000-0xec01ffff irq 16 at device 11.0 on pci1
em0: Ethernet address: 00:20:ed:88:15:f6
em0:  Speed:N/A  Duplex:N/A
pci1: <mass storage, RAID> at device 12.0 (no driver attached)
atapci0: <SiI 3112 SATA150 controller> port 0xac00-0xac0f,0xa800-0xa803,0xa400-0xa407,0xa000-0xa003,0x9c00-0x9c07 mem 0xec021000-0xec0211ff irq 18 at device 13.0 on pci1
ata2: channel #0 on atapci0
ata3: channel #1 on atapci0
atapci1: <nVidia nForce2 UDMA133 controller> port 0xf000-0xf00f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 9.0 on pci0
ata0: channel #0 on atapci1
ata1: channel #1 on atapci1
fwohci0: <1394 Open Host Controller Interface> mem 0xed084000-0xed08403f,0xed083000-0xed0837ff irq 20 at device 13.0 on pci0
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 8a:17:d4:ff:ff:00:20:ed
fwohci0: Phy 1394a available S400, 3 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 8a:17:d4:00:20:ed
fwe0: Ethernet address: 8a:17:d4:00:20:ed
fwe0: if_start running deferred for Giant
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc000ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci3: <ACPI PCI bus> on pcib2
pci3: <display, VGA> at device 0.0 (no driver attached)
pci3: <display> at device 0.1 (no driver attached)
fdc0: <floppy drive controller> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0: <ECP parallel printer port> port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
ppbus0: IEEE1284 device found /NIBBLE/ECP
Probing for PnP devices on ppbus0:
ppbus0: <Hewlett-Packard HP LaserJet 3150> HP GDI,ECP18
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
orm0: <ISA Option ROMs> at iomem 0xd2000-0xd67ff,0xd0000-0xd17ff,0xc0000-0xccfff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 2191239289 Hz quality 800
Timecounters tick every 10.000 msec
ad0: 156334MB <Maxtor 6Y160P0/YAR41BW0> [317632/16/63] at ata0-master UDMA133
acd0: DVDR <PLEXTOR DVDR PX-712A/1.05> at ata1-master UDMA33
ad4: 238475MB <WDC WD2500PD-07FZB0/02.05D02> [484521/16/63] at ata2-master SATA150
cd0 at ata1 bus 0 target 0 lun 0
cd0: <PLEXTOR DVDR   PX-712A 1.05> Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present - tray closed
Mounting root from ufs:/dev/ad0s3a
em0: Link is up 100 Mbps Full Duplex
OSS: Output timed out (sync) on device 2
OSS: Output timed out (sync) on device 2
OSS: Output timed out (sync) on device 2
OSS: Output timed out (sync) on device 2
OSS: Output timed out (sync) on device 2
OSS: Output timed out (sync) on device 2
OSS: Output timed out (sync) on device 2
OSS: Output timed out (sync) on device 2
SoftOSS: Audio device #8 is write only
SoftOSS: Audio device #9 is write only
SoftOSS: Audio device #10 is write only
SoftOSS: Audio device #8 is write only
SoftOSS: Audio device #9 is write only
SoftOSS: Audio device #10 is write only
OSS: Busy...cannot unload drivers(2)
OSS: Busy...cannot unload drivers(2)
stray irq10
GraveR
 
Posts: 1
Joined: Fri Oct 29, 2004 8:35 pm

poker casino76

Postby poker casino76 » Sat Feb 18, 2006 8:59 pm

poker casino76
 


Return to BSD

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests