Troubleshooting

From Open Sound System
(Difference between revisions)
Jump to: navigation, search
m (minor edit)
m (minor edit)
Line 15: Line 15:
 
*Does osstest work?
 
*Does osstest work?
 
*Are the outputs muted in the mixer?
 
*Are the outputs muted in the mixer?
 +
*Is the default soundcard (the one linked to /dev/dsp) the one connected? If not, see [[Tips_And_Tricks#Changing_the_default_sound_output_used_for_.2Fdev.2Fdsp | here]] how to change that.
 
*HDAudio: Are the jacks detected by OSS as output, actually the jacks connected to the speaker?
 
*HDAudio: Are the jacks detected by OSS as output, actually the jacks connected to the speaker?
 
*Is this an hardware issue?
 
*Is this an hardware issue?
Line 27: Line 28:
  
 
== I can't get multiple sound clients to play on the same device ==
 
== I can't get multiple sound clients to play on the same device ==
*On FreeBSD version, multiple clients to same device aren't supported. Either set programs to use separate devices, or use sound server like aRts, esd, etc.
+
*multiple clients to same device aren't supported on FreeBSD version. Either set programs to use separate devices, or use sound server like aRts, esd, etc.
 
*Is vmix loaded?
 
*Is vmix loaded?
**If so, make sure vmix1_masterdev in vmix.conf is set to the output device's device index.
+
**If so, make sure vmix1_masterdev in vmix.conf is set to the output device's device index (this can be determined by 'ossinfo -a').
  
 
== I can't get sound/volume control from an application! ==
 
== I can't get sound/volume control from an application! ==
 
*See [[Configuring_Applications_for_OSSv4 | Configuring Applications for OSSv4]]
 
*See [[Configuring_Applications_for_OSSv4 | Configuring Applications for OSSv4]]

Revision as of 00:06, 20 May 2008

Contents

General

  • Always read your drivers' manpage.
  • Always test with osstest
  • When consulting the forum, attach the output of 'ossinfo -v3' and 'ossmix'.

How do I...

  • Change mixer settings - ossmix (command line), ossxmix (GUI)
  • Start and shut down OSS - soundon, soundoff (both require root)
  • Save and restore mixer settings - savemixer (saving requires write permissions for mixer.save)
  • Build OSS from source
  • Other Tips And Tricks

I can't hear any sound!

  • Did OSS load at all?
  • Does osstest work?
  • Are the outputs muted in the mixer?
  • Is the default soundcard (the one linked to /dev/dsp) the one connected? If not, see here how to change that.
  • HDAudio: Are the jacks detected by OSS as output, actually the jacks connected to the speaker?
  • Is this an hardware issue?
    • Are the speakers muted?
    • Is the soundcard connected correctly to the speakers?
    • Do other drivers available for your OS (e.g. ALSA for Linux, FreeBSD native) work?

I hear noises!

  • Many soundcards' hardware requires output mixers be set to less than maximum (60% at times).
  • Set vmix0-src to an higher setting.
  • Is the cable from the soundcard to the speakers connected correctly? Could it be too long?

I can't get multiple sound clients to play on the same device

  • multiple clients to same device aren't supported on FreeBSD version. Either set programs to use separate devices, or use sound server like aRts, esd, etc.
  • Is vmix loaded?
    • If so, make sure vmix1_masterdev in vmix.conf is set to the output device's device index (this can be determined by 'ossinfo -a').

I can't get sound/volume control from an application!

Personal tools